안녕하세요,

UCI는 또 오랜만에 들고 왔네요....

이번엔 J3용 런쳐입니다
... J3 전용 J3 전용..S9에 넣고 뭐가 안된다느니 하지 마세요...

J3를 친구를 통해 구하게 되었는데 S9 UCI들이 제대로 호환 되질 않아서 다시 또 직접 고쳐 쓰기로 했답니다.

우선, 급한대로 제가 주로 사용하는 UCI 위주로 수정을 했는데 (메인: Aero VTX) 다른 UCI는 어떻게 호환제대로 되나
직접 확인해본바는 없으니 사용자 분들께서 테스트 해주시고 피드백 주시면 수정해 나가는 식으로 할 겁니다.

아... J3 런쳐 뜯어 보면서 알게된 사실인데... 사진 뷰어에 사용되는 "멀티 터치" ... 이 기능을 다른 UCI에서도 사용 할 수 있을듯 합니다.... 좀더 연구해봐야 확인 가능한 부분이지만...;;

지금 시각이...새벽 2:58분 이군요...

피곤해서 프레임 런쳐는 나중에 올려드립니다.
일단은 기본 24프레임 런쳐입니다.

(개인적으로 프레임 런쳐 사용 비추... 사용하더라도 30 프레임 정도만...: 코원에서 기본 프레임수를 괜히 24프레임으로 잡은게 아닙니다...)


▶ 런쳐 수정 History

GILgaMEsh의 표준런쳐 제작 프로젝트 1,2,3차 런처
-> 클라우스의 런쳐 수정
-> GILgaMEsh의 런쳐 수정
-> GILgaMEsh의 J3용 런쳐로 이식

▶ J3 기본런쳐와의 차이
 

1) text scrolling 부 수정

- 클라우스가 스크롤링 되지 않을 경우 작동안하는 방식으로 효율화.
단, 'nw의 dark evolution에서는 태그 정보가 너무 길경우, 스크롤 되지 않음.

- 이것 때문에 추후 변경 예정


2) 메뉴 이동시,(UCI간 이동시) 배경 변경

- 브라우져, 동영상, DMB, 사진 모드 진입시, 검은 배경으로 대체 (모드 변경 속도 향상)
- 설정(setting) 모드 진입시 J3 기본 배경으로 대체 (가독성 향상)


3) S9 UCI의 호환을 위해 J3 런쳐 함수, S9 런쳐 함수 혼합

- S9 UCI를 전부 테스트 해보지 않고 본인이 주로 사용하는 UCI에서만 테스트 했기때문에 100% 호환이라고 보장 못함.(즉, 사용자들이 직접 테스트 해보고 제게 피드백을 달라는 뜻입니다.)

- S9 UCI호환을 하려고 수정한 부분들 때문에 J3의 기본 기능적으로 문제가 생기는경우도 제보 바랍니다.


4) Typist 에서 한글 자판 사용 가능

- 기존 S9 UCI 호환용 런쳐에서 타이피스트에서 한글 자판 사용불가능 하던 문제 수정


v0.5


1) 배터리 잔량이 항상 0 으로 표시되는 문제 수정

 - 기본 메뉴 UI 즉, 기본 동영상, 디엠비, 등의 메뉴에서 배터리 잔량이 항상 0으로만 표시되던 문제 수정

2) 프레임 런쳐 추가

 - 기본 프레임수인 24 fps 런쳐 이외에 30, 40, 60 fps 런쳐를 추가 (50, 120등의 실험성 fps는 제외)
(120fps는 J3 cpu에 버거움...)

▶ 설치법

압축을 해제하여 프레임수 별로 나뉜 폴더에서 launcher.swf 파일을 하나 골라서  System\Flash UI 폴더안에 집어넣는다

(프레임 런쳐가 무엇인지 모르시는 분들은 그냥 24 fps(BASIC) 폴더에 들어 있는 launhcer.swf 파일 하나만 넣으시면 됩니다.

<다운로드>

 


본 파일을 무단수정/무단배포 하거나
글을 무단복사 하는것을 금합니다.
이 것은 법적인 문제 이전에 제작자에 대한 기본 매너입니다.
본 포스트의 주소를 링크로 퍼가는 것은 상관없습니다.







저작자 표시 비영리 변경 금지
신고

'S9 & J3 > [ UCI ] J3' 카테고리의 다른 글

J3용 베타 런쳐  (8) 2010.09.20
[v0.6] J3 용 런쳐  (21) 2010.09.20
[v0.5] J3용 런쳐  (19) 2010.09.11
  1. 제이 2010.09.11 09:46 신고

    제가 첫 댓글이네요 감사합니다. ^^

    • BlogIcon naubull2 2010.09.11 23:56 신고

      ㅎ블로그에는 피드백을 많이남기시지 않더군요 ㅎ

  2. 행운법사 2010.09.11 10:15 신고

    음냥... 기본 UI(설정이나 라디오 같은...)을 사용했을 때는 배터리 잔량이 0으로 나오네요 ㄷㄷㄷ

  3. 행운법사 2010.09.11 12:05 신고

    루나님의 윈도폰7 UCI 속도가 살짝 느려진것 같기도 하네요...

  4. 똘핑 2010.09.12 01:44 신고

    감사합니다.
    타이피리스트 때문에 고민이 많았었는데 ㅠ
    근데 음악 재생할때요~ 파일 넘길때 버튼이 반대이더라구요!! 이건 클라우스님때도 그렇던데;;
    다음곡 버튼 누르면 이전곡으로 넘어가는데 이 문제를 수정해주세요!

    • BlogIcon naubull2 2010.09.14 13:06 신고

      수정되었습니다. 다음 업데이트에 넣어드리겠습니다.

    • BlogIcon naubull2 2010.09.14 13:06 신고

      수정되었습니다. 다음 업데이트에 넣어드리겠습니다.

  5. osirptpm 2010.09.14 00:41 신고

    정말 잘쓰고있어요~
    그런데 한가지 오류가 있는것같습니다.
    블랙네온쓸때 디엠비아이콘을 배경화면에 내놀수가 없네요..
    런처를빼고하니 정상작동합니다. 닼에볼을 쓰다보니 이 런처가 정말 필요하더군요.
    혹시 수정 가능하면 부탁드릴께요..

    • BlogIcon naubull2 2010.09.14 13:05 신고

      흠... 제가 블랙네온을 쓰질 않아서;;

      자꾸 블랙네온이나 포토제닉 관련 오류들을 호소 하시네요...

      다른 문제 모두 해결하고 나면 이것도 보겠습니다;;(죄송하지만 개인적으로 당장 급한 문제는 아니니....)

    • osirptpm 2010.09.15 23:02 신고

      물론이죠. 여유가 되시면 해주세요.
      나름 바쁘실텐데 제가 더 죄송하죠ㅎ

    • BlogIcon naubull2 2010.09.16 00:00 신고

      아니 뭐 죄송할것까지야 없죠ㅎㅎ

  6. osirptpm 2010.09.18 17:21 신고

    쓰다보니 몇가지 문제점이 또 발견되어서요..
    h2oUCI사용중인데요 락 설정후 다른 UCI (예:블랙네온 디터치)에서 다시 h2o로 진입하면 락화면이 떠야되는데 뜨질않아서요. 그리고 설정 모드에서 배경화면 안나오게 하셧다고 위에써져있는데 배경화면이 다시 설정되있는걸로 뜨더군요. 또 h2o위젯 누르고 스크롤링시 나는 오류또한 그대로구요..

    근데 이상한건.. 런처 처음 넣고서는 잘되다가 무슨이유에서인지는 알수없으나 UCI바꾸면서 이짓저짓하다보면 저런 증상이나온다는거에요.. 게다가 전에 올렷던 DMB문제또한 저절로 고쳐?졌다는.. 이외에도 가지가지라능..

    이상해서 다시 SOL파일들 지우고 런처 다시 넣으니까 또 DMB문제 발생했구요..

    너무 이상한 증상이라서 이게 수정가능할수나 있을지.. 기본런쳐일때는 닼에볼빼고는 멀쩡한데 말이죠..흐음.. 참. 클라우스님의 브라우저랑 텍스트 뷰어를 사용하는데요. 배경화면을 약간씩 투명하게 해서 쓰고있습니다. 그것때문에 설정모드에서 배경화면이 나오는 문제가 발생되는것같기도 하네요.

    S9용이면 이런 글은 올릴생각조차 못하지만.. 이건 j3용이니.ㅎ;; 수정해주셨으면 좋겠네요. 하지만.. 불가능하다면..(이유가 어찌되었든) 어쩔수없으니 크게 신경쓰지않으셔도..

    • BlogIcon naubull2 2010.09.19 13:32 신고

      01. 다른 UCI에서 h2o 진입시 락스크린이 뜨는경우는 첫 구동시에만 한해서 랍니다. h2o로 켜서 다른 UCI-> 다시 h2o로 갈경우 원래 락 안뜹니다.

      02. 위젯 누르고 페이지 이동시 문제는 런쳐가 아니라 위젯을 새 버젼을 받으시면 됩니다;;(애시당초 런쳐문제가 아니었거든요 ㅎ)

      03. DMB문제라...DMB메뉴가 뜨지 않는 일부 메인메뉴의 경우도 런쳐 문제가 아니라 S9 FSCommand와 J3 FSCommand 중 펌웨어 버젼 확인 부분의 차이 때문인것 파악되었고요, (즉 버그는 아니라 원래 충돌 나는 부분 이라 손볼 예정이고요)

      04. 텍스트 뷰어/브라우져 저도 사용합니다만 설정 메뉴에서 J3기본 배경으로 뜨게 잘 되는데요;;

    • osirptpm 2010.09.19 19:33 신고

      01. 아.. 다른 uci로 구동후 h2o로 갈때 처음 한번만뜨는거였군요.. 제가 착각했나봅니다..

      02. 새 버전에서 문제가 발생했다는 소리였는데..이게.. 1.2버전 압축폴더에 mplayer폴더 안에있는거가아니라 밖에있는걸로 덮어씌우는거엿군요; 수정날짜보고알았다는.. 결론은 문제 해결...

      03. 그렇군요.. 근데 왜 갑자기 문제가 해결됬었던 걸까요? ㄷㄷ 알수가없다능..

      04. 음 전 계속 그래서 다른것들 다빼고 텍스트 뷰어/브라우져만 넣고 하니까 문제 없더군요 그런데 h2o사용해서 설정모드로 진입하니까 문제가 발생하네요. 제가 지식이 짧아서 이게 런처문제인지 아닌지 모르겠다는..(이게 키자마자 바로 설정모드 들어가면 잘되는데 브라우져랑 텍스트 뷰어 한번씩들어갔다가 설정모드로 가보면 문제가 발생하더군요.)

    • BlogIcon naubull2 2010.09.19 23:31 신고

      04. 흠... 네이버 카페에서도 설정 모드 배경관련 이야기 하신분이 계셨는데 혹시 동일인이신지는 모르겠으나... 좀더 구체적으로 이렇게 이렇게 하면 100% 이렇게 되더라 하는 걸 알 수 있다면 문제 해결에 도움이 크게 될것 같습니다 ㅎ...제 기기에서는 어떤 UCI에서도, 설정 모드 배경이 일정하게 잘 작동하는것을 확인했거든요...ㅠ (J3 3.21firm으로요)

    • osirptpm 2010.09.20 18:44 신고

      04. 음. 방금 해봤습니다. 일단 flash ui 폴더를 비운후 클라우스님의 텍스트뷰어와 0.5버전 런처를 넣고 실험해보았습니다. 부팅시 바로 설정모드 진입시 문제가 없었습니다. 하지만 부팅후 클라우스님 텍뷰를 켰다가 메인으로 돌아온후 설정모드로 가면 기본배경이 아닌 설정된 배경으로 나오네요. 그런데 ... 기본런처에서도 이런현상이 나타나는것을 확인했습니다.... ㄷ? 생각해보니까 닼에볼쓰기전에 기본런처쓸때도 이런 현상이 나타났었다는.. 이제 보니 런처와는 관련이 없는 문제인가 싶기도 하지만 길가님 글보니까 가독성 향상을 위해 기본배경 나오게 해놓셨다고 했는데 문제가 발생해서 올려봅니다. 그리고 전 카폐에 배경관련 글을 올린기억이 없는것 같군요.(가능성은 낮지만.. 기억을 못하는것일수도..)

    • BlogIcon naubull2 2010.09.21 22:59 신고

      구체적인 확인 감사합니다...
      좀더 확인해보도록 하겠습니다 ㅎ

+ Recent posts